1. 首页
  2. 运营与推广
  3. 内容运营

ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞

  小程序创业扶持计划 实现月入10万创业梦

  ecshop漏洞于2018年9月12日被某安全组织披露爆出,该漏洞受影响范围较广,ecshop2.73版本以及目前最新的3.0、3.6、4.0版本都受此次ecshop漏洞的影响,主要漏洞是利用远程代码执行sql注入语句漏洞,导致可以插入sql查询代码以及写入代码到网站服务器里,严重的可以直接获取服务器的管理员权限,甚至有些网站使用的是虚拟主机,可以直接获取网站ftp的权限,该漏洞POC已公开,使用简单,目前很多商城网站都被攻击,危害较大,针对于此我们SINE安全对该ECSHOP漏洞的详情以及如何修复网站的漏洞,及如何部署网站安全等方面进行详细的解读。

  ecshop漏洞产生原因

  全系列版本的ecshop网站漏洞,漏洞的根源是在网站根目录下的user.php代码,在调用远程函数的同时display赋值的地方可以直接插入恶意的sql注入语句,导致可以查询mysql数据库里的内容并写入数据到网站配置文件当中,或者可以让数据库远程下载文件到网站目录当中去。

ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞
ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞
ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞
ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞

  此referer里的内容就是要网站远程下载一个脚本大马,下载成功后会直接命名为SINE.php,攻击者打开该文件就可以执行对网站的读写上传下载等操作,甚至会直接入侵服务器,拿到服务器的管理员权限。

ecshop 全系列版本网站漏洞 远程代码执行sql注入漏洞

  ecshop漏洞修复

  目前ecshop官方并没有升级任何版本,也没有告知漏洞补丁,我们SINE安全公司建议各位网站的运营者对网站配置目录下的lib_insert.php里的id以及num的数据转换成整数型,或者是将网站的user.php改名,停止用户管理中心的登录,或者找专业的网站安全公司去修复漏洞补丁,做好网站安全检测与部署。对网站的images目录写入进行关闭,取消images的php脚步执行权限。

原创文章,作者:我来投稿,如若转载,请注明出处:https://www.zengqueling.com/ecshop-%e5%85%a8%e7%b3%bb%e5%88%97%e7%89%88%e6%9c%ac%e7%bd%91%e7%ab%99%e6%bc%8f%e6%b4%9e-%e8%bf%9c%e7%a8%8b%e4%bb%a3%e7%a0%81%e6%89%a7%e8%a1%8csql%e6%b3%a8%e5%85%a5%e6%bc%8f%e6%b4%9e/

联系我们

15602395067

在线咨询:点击这里给我发消息

邮件:eden7@qq.com

工作时间:周一至周五,9:30-18:30,节假日休息

QR code